AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Sensor Questions - Page 5 of 30


Please tell me the location(s) of the oxygen sensor(s) and give me any clues as to which one, if any, is giving me the "Service Engine Soon Light". The light has been constant for several months. I haven't noticed any difference in performance, except perhaps lower gas mileage. Your help is greatly appreciated, especially since I am hoping to fix the ...
1995 Altima won't start - Battery good, starter good. Changed spark plugs. Changed wires. Changed distributor cap & rotor. Performed spark test (spark looked weak, but is present at plugs & coil). Tested coil primary (1.4ohm) & secondary (13.43ohm) resistance. Tested power transistor resistance (had resistance where it should). Checked fuel pump fuse, good. ...
I have been having non stop problems with my car. I accidentally bought a kia optima. I was only 17 and had no idea what auto suggestion was. Now I'm 24 and I have been paying for a car that does not run. Let's say I'm driving the car right now on the free way. The engine is warmed up and all of the sudden it will just die. So there I am on the freeway ...
Hi there, You guys have been so helpful to me in the past, and I'm back with yet another car problem. I have a 1997 Mercedes C-280. About once a month for the past 4 or 5 months, my car has stopped no warning, either when I am sitting in traffic on the freeway, slowing down off an exit, or just sitting there when my car is idle. Usually, I have ...
I need to replace the oxygen sensor on my 1997 Hyundai. Is there only ONE?
Where is the camshaft position sensor (cmp) located? checked with car md. need to replace to get check engine light off before inspecttion. thanks mike
I have a 2004 Ford F-150. Recently, I had a back-up sensor system installed. It worked fine for a couple weeks, and then decided to sound every time I would back up even though there was absolutely nothing behind me. I took the truck back to the service center that initially installed it, and they reprogrammed something. Same thing - after a couple ...

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities