AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Sensor Questions - Page 29 of 30


Car died on me at a gas station. Drove fine. Stopped for gas, cut the car on and it would not turn over. Not getting a clicking noise or anything. Car eventually died. Got a new alternator, a new starter, battery fully charged, 2 sensors changed in the engine and my car still will not start. What is the problem?

i have literally a flawless car and i installed a "vertex" performance chip ]under the hood and after so many days i got a check engine light . WELL I FOUND OOUT YOU CAN DO A LITTLE car hack code and i did it and it said i had somthing worng withthe oxygen sensor or soomthing .. thats where that chip is actually pkugged into the toP OFF sorry ...

How can i tell if timing is off? I just put new chains, tentioners, gjides and gears in. Im wondering if im off a tooth. Limited power...4000rpm..max Barely stays running at idle and sometimes dies. Codes are: p0300,p0302,p0304,p0306, p2119,p0449 ive test the vent valve....it works! Ive swapped coils of 5 and 6....didnt make difference. When i hold rpms ...

I've recently had my brakes replaced on the front tires of my Ford Explorer XLT. Now the front left brake intermittently grinds when I slow down and then a generic sensor flashes on. I've had them inspected by Firestone and they say the brakes look good. I'm concerned the brakes are unsafe. Help!

I was told by a mechanic than my cooling fan motor was out, I did not have them replace it. 1 day after getting my honda back the check engine light went off and my fan motor is working. Could it juat b the sensor or have you heard of a fan motor working then not working??

I have an 01 Saturn sl2 with almost 200k miles (recently acquired). Car was used to many short trips last 4-5 years of its life. I'm now driving five days a week, over 200 miles weekly. I noticed the car would sometimes seem to "accelerate" as you were trying to slow down and often the engine would race (3krpms) when car was running in ...

Hi I brought a VW beetle 2004 and it was driving fine then is went through a storm and the check engine light has come on nothing else is to worry can drive fine every thing works fine I have been told the a sensor could of gotten wet but I wanted a second opinion


Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities