AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Sensor Questions - Page 12 of 30


was recently informed (at regular oil change) that no-oil showed on dip-stick upon arrival (137.xxx). haven't noticed drips under car, or "blue-smoke"(burning oil); always have regular Valvoline changes/maintenance...and eng. temp gauge did not show irregular level. did have "ck eng light" about 1-yr ago/replaced cat convertor sensor & ...
My Chevy Blazer is not getting any gas to carburetor. Which sensor could be malfunctioning?
My oil pressure sensor connecter was leaking oil, a lot to, so I changed out the oil pressure sensor , thinking it failed. The one I got from napa has two prongs inside the sensor it's self and the new connecter has two wires , when the O.G one had only one green wire on the connecter and one prong on the sensor what do I do. Is it the wrong part ,or do I ...
Roughly two weeks ago my tire pressure light came on. I proceeded to the gas station to check the pressure. It was a bit low, I filled it and the light went off. This has been going on for two weeks now everyday we fill the tires and within hours the light comes back on. We took it to a mechanic to have it checked and low and behold he advised us that the ...
car starts, runs about 6 minutes, check engine light comes on and engine dies. cranks, but won't start for about 30 minutes. just changed coolant temp sensor, still doing same thing. Could it possibly be the Catalytic converter or the ECM?
I recently did not pass the emissions portion of my smog check (CA). Specifically the "HC (PPM)"section failed at 15mph. It measured 101 with a max allowed being 61. To remedy this, I had my mechanic replace the oxygen sensor (which was a previous problem months before) as well as a major tune-up and fuel injector cleaning. I went back to retake the smog ...
My VSC and Engine Light started going on every time I filled up the gas tank of my Lexus IS300. Since my battery is bad I thought it may be due to that. I was on the highway and car stopped accelerating. I drove it home slowly when I put in park to open the gate to the driveway the car wouldn't drive or reverse. My husband changed the battery thinking ...

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities