AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Engine Questions - Page 46 of 87


car starts, runs about 6 minutes, check engine light comes on and engine dies. cranks, but won't start for about 30 minutes. just changed coolant temp sensor, still doing same thing. Could it possibly be the Catalytic converter or the ECM?
I mistakenly took out the distributor of my Ford Taurus and didn't take heed to the TDC or even mark my distributor location. I put the distributor back in and started the car (which obviously didn't start) and perhaps good fortunate when I attempted at taking it out and put it back in at a different rotation and the car started just fine. However, now ...
There is a squeaking noise coming from the front of the engine, near the fan and belts on my Dodge Durango. It's louder when the engine is idle, but you can hear it all the time. What might be causing this?
My VSC and Engine Light started going on every time I filled up the gas tank of my Lexus IS300. Since my battery is bad I thought it may be due to that. I was on the highway and car stopped accelerating. I drove it home slowly when I put in park to open the gate to the driveway the car wouldn't drive or reverse. My husband changed the battery thinking ...
For past month, my Subaru Forester frequently seems to clunk/jump at slow speeds, mostly when I pull in/out of parking spot or driveway, when engine is still cold. It's also leaking what I presume is oil (brown fluid). The leak has gone on for 3 months, the clunky gear shift or steering has been happening for 1 month. I checked transmission fluid, it ...
Where is the ETS sensor located on this vehicle? The ETS "Check Engine" light came on 3 days ago and the gears seem to shift hard and change from 1st to 2nd to 3rd and so on. It is an automatic transmission, the fluid is clean and I have never had any problems with the transmission. Is it possible that the ETS sensor would cause this hard shifting?
my 69 firebird is blowing white smoke out the tail pipes also a creamy color liquid is coming out the tail pipe on the passenger side their is no water in the oil coolant seems fine,spark plugs look normal and no water or oil leaks.engine sounds normal.

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities