AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Coolant Questions - Page 8 of 13


my 69 firebird is blowing white smoke out the tail pipes also a creamy color liquid is coming out the tail pipe on the passenger side their is no water in the oil coolant seems fine,spark plugs look normal and no water or oil leaks.engine sounds normal.
The coolant light in my 2001 Saturn SL1 came on. I was advised to replace the water pump and temperature gauge. I did and the light went off. A short time later, the light came back. Diagnostics did not point to other causes for the light so it was suggested that it was a fuse. It has been a year since I replaced the water pump and temperature gauge. No ...
Temp guage starts to climb quite a bit when the car is idling in traffic for 4-5 mins. when i take off, the guage goeas back down to almost normal. Both fans are running and the coolant overflow bottle is full. Had a new radiator put in 2 years ago, just changed the oil and it is good. runs fine when car is moving, but guage climbs when idiling too long
My Saturn's A/C unit seems to to leaking freon!I Within the last couple of years I'd add coolant to the system, and I'd have cool air, but within a week, nothing. Is this an easy fix? Is it just a matter of replacing or plugging up a hose? I don't want to spend too much money. I've already received a quote of $64.xx, but that's just labor!
My Oldsmobile Intrigue fan comes on all the time. I put the antifreeze in the coolant and it still won't turn off. This has been going on for three days and now the lights on the dashboard come on and they won't go off and now my battery went dead so what can I do to fix the problem?
I have a 2000 Buick Century with about 150,000 miles on it. It has been relatively trouble free. Recently, the "low coolant" light began to come on. I took the car into a garage where I was told there was oil in the coolant and the sensor had been compromised. The cooling system was flushed and cleaned and a new sensor installed. The "low coolant" ...
I have a 1997 Mercury Sable that I just bought used, and is in very good condition.. except the heat doesn't work. The symptoms: car always blows cold air, no matter what I have the temp setting on. The dial that controls heat/ac/vent/defrost is VERY loose and doesn't "click" into any specific place, only sometimes does it "click" into something, making it ...

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities