AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Start Questions - Page 4 of 103


Patty, I really hope you can help me out. I have purchased a 1995 Eagle Talon from my brother. The car had a problem. It would start and stop and not move.My brother tried to have it fixed back in the day with no success. Recently, I found out that it needs an ignition module and change of wires. My question is what is an ignition module and will this help ...
Ms.Patty, I have a question and hope you can help... I own a 95 Dodge Stratus that won't start. It will try, i can tell it's not the battery(lights come on). My only thought was maybe the fuel injection pump or maybe the cam position sensor. How can i tell, without replacing both, (I am really broke!!) which is causing the problem? And I heard that you ...
Hey, i just left a question about my dodge stratus not starting and then went on to reading about Oprah, who i LOVE!! doing more good deeds... if I could give anyone anything... I would give cars to the poor people that have children (been there done that, and it's HARD), or granting last wishes for people with terminal cancer. My dad was diagnosed with ...
I have a 2002 Saturn that all of a sudden started chugging like its out of gas which its not,someone told me it could be my fuel intake valve?
I have 2003 Monte SS.When I start my car and put it in drive and press on the accelerator it sounds like water swishing in the firewall of the car. It runs great,just can't figure out wheat the water noise is. Any answers?
I have a 1999 Mazda Protege LXIT currently has 140,000 miles. I had the transmission fluid (not the transmission filter) in the transmission changed at 110,000. As it is 140,000 now I think that it is time for another service. Also the gear shifts a little hard than before but overall it works just fine. The previous owner also informed me that the ...
I have a 1994 Ford Aerostar 3.0 I have bought everything for the electrical system and "No start" so maybe..Timing Belt? How to you check easily ?

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities