AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Heat Questions - Page 8 of 36


This is a 94 car. After my car engine has heated up, (not just when the engine initially heats up from being off for a long time)but say like driving 20 miles on open road, when decelerating the engine will lower the initial RPM
What would make my radiator overheat? There is steam sometimes. The temperature gauge does not get to the 260 mark all the time. I don't always have to add a lot of water or antifreeze to it either. Please tell me what the problem could be. thank you
On my 99 windstar with 135k miles, it starts and temp. gauge goes immediately to normal reading. Later, after it warms up, it reads either full hot(in warm weather) or full cold(in cold weather below freezing) every time. This produces a CEL and the code is for either overheat or running cold, depending on the ambient temperature. What would produce this ...
Hi there, You guys have been so helpful to me in the past, and I'm back with yet another car problem. I have a 1997 Mercedes C-280. About once a month for the past 4 or 5 months, my car has stopped no warning, either when I am sitting in traffic on the freeway, slowing down off an exit, or just sitting there when my car is idle. Usually, I have ...
My car takes three to five turns of the ignition before starting in hot weather or driving for at least 20 minutes in mild weather. When filling up, a lot of air leaves the tank and the pump keeps kicking off every 0.2 gallons. I know that the car needs fuel and keep pumping. After about 2 gallons it takes the fuel without kicking off the pump. The ...
I have a 99 mercury villager with 80000 miles. For the last couple of months I have had a problem with the heat, it takes for ever to heat up and when it does, it is not a real hot heat. It has never overheated, nor is there any sign of fluid leaking. The other day I took it to a repair shop to have them check the heat....they were a tire/muffler repair ...
I have a 1997 Ford Explorer XLT with 4.0 Engine. I had the engine rebuilt 1 week ago. The check engine light comes on after about 5 minutes of use and the temperature gauge goes up to about 3/4 hot when I am driving, but goes back to normal when I come to a stop. One time it actually over heated. I took the vehicle back and was told that the new ...

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities