AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Fan Questions - Page 9 of 15


My 1999 Dodge Durango is making a loud squeaking noise near the fan in the front, when I start it and when driving. What could be the problem?
My Chevrolet Tahoe has no fan heat in front.The aux fan heat works in back. Is it a bad fuse or fan?
Had coolant leak... Car not over heating but on way then coolant started leaking... Took it in changed coolant, radiator fans, water pump, timing belt AND thermostat.... B4 coolant leak, the heater would work good for A day, 50% most the time or just not work. Took car in.. Had work done, heater worked great for the first day then went back to ...
My name is Sondra n I just bought my Cadillac. It ran hot so I replaced the thermostat after realizing it needed it. Engine fans not working and hose coming from radiator is building up air pressure instead of water pressure. Also still runs hot. Also the reservoir is building up air pressure. What could fix this problem. Heater also does not blow hot air ...
My condenser fan on my 2006 Honda Accord quit coming on. I put a little water in the radiator. It started to spin again. But, it will still overheat, when The car switches gears. As I keep driving, it cools off. My code reader says it's a coolant temp sensor. On the highway, it stays cool, so I don't think it's the thermostat. Any advice would be ...
Why is my 2005 Chevrolet Astro temperature gauge going over the half mark like it's overheating and this only happens when I'm in traffic? I fixed the fan, thermostat, sensor and they check the radiator and it's fine. Is it normal for this car to do that? Or what should I do?
We had to replace the radiator in our '99 Volkswagen Beetle. It was running before this. Unplugged the cooling fan. Put radiator back in, plugged fan in. Now when we try to start car, alarm comes on and lights start flashing, but car will not start, nothing at all except alarm. No keyless remote with this car.

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities