AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for Ac Questions - Page 168 of 291


My Suzuki XL-7 vacuum hose has detached from the transmission. I don't see where to reattach it, where should I look?
I have a Chevy Tahoe that has 170,000 miles. It is time to get the transmission flushed. The garage that did it last time (almost 80,000 miles ago) is no longer in business. I have my tire rotations and oil changes done at a local Firestone, but they will not do a flush on a transmission with over 100,000 miles. They say they son't do cars with over 100K ...
I am trying to replace the starter, which should be a relatively easy fix. The upper mounting bolt for the starter was gone and is the reason why the casing on the starter broke around the other mounting bolt. I bought another bolt for the hole, but the problem is there is no way to get your hand or a wrench in that little space to put that second, upper ...
Temp guage starts to climb quite a bit when the car is idling in traffic for 4-5 mins. when i take off, the guage goeas back down to almost normal. Both fans are running and the coolant overflow bottle is full. Had a new radiator put in 2 years ago, just changed the oil and it is good. runs fine when car is moving, but guage climbs when idiling too long
Approximate cost to replace front and rear brakes, pads and rotors for 2007 Chev Mabibu Maxx
I have a 1997 Camry that had been in an accident and gone off the road on the passenger side. It makes a loud clunk noise on the front passenger side, sounding like a strut. I do not think it is a strut. But the bracket under the hood is twisted from the accident. Where is this sound coming from?
One day I went to back out of a parking spot, and my reverse gear would not engage. I went forward a bit, and then had a guy help me push it into the parking lot. I had all of my forward gears. I didn't notice unusual tacking in the low gears, however when I was about 50-60 mph, my tachometer would read 3000. When I let off the accelerator, it went down to ...

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities