AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionSearch for 2013 Dodge Avenger Questions - Page 1 of 1


My check engine light came on on my 2013 Dodge Avenger. The car has only 1600 miles. Checked the gas cap, the light still has not gone out after several stops. Also the remote starter on the key fob won't start the car.
I have been doing all the proper caring for my 2013 Dodge Avenger like oil changes every 3000 to 5000 miles. Making sure my gas tank is always topped off with fuel 87 grade sometimes 91 grade. I also use 44k for my fuel as well. Two days ago my check engine light is on. I thought I was taking care of my car. I have driven it and no problems or trouble. Why ...
I bought my 2013 Dodge Avenger brand new in November 2012, I have never had any problems with it or any lights come on except the low tire light, today I started my car and the check engine light came on and hasn't gone off. Do you have any idea what might be the cause?
My gas cap warning came on about a week ago on my 2013 Dodge Avenger. I tried tightening it several times but the warning stayed on. Now my engine light is on.
We drove my 2013 Dodge Avenger today stopping and starting it a few times with no issues. We added gas on the way home and everything was fine. A few hours later after being at home, we went to leave and the car would not start. It turned over but died instantly. It acted like it was flooded. We let it sit a few hours and tried again and it still won't ...
How can I tell if someone has tampered with the safety cover that sits just under the gas cap on my 2013 dodge avenger

2013 Dodge Avenger,5000 mileage, it running very well for 2 weeks, one day, after running very well for 60 miles, then I stopped it for about 40 minute at parking place, after that, it did not start without crank, the battery is ok with 12v, start is good. can you help me find the possible problems ? Thanks.


Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities