AskPatty Certified Female Friendly Logo

Hey everyone, so I own a 2010 GMC Yukon SLT. Recently a problem had been annoying me much more than before, note that the problem actually had been since quite a few years. Anyway, so whenever I slowdown the RPM goes as low as 500 RPM, not sure if that's normal. Anyway so if I want to accelerate the moment I step on the pedal there is a noticeable clicking sound that you can also feel from the engine. I just hope someone helps me out on this one, because I just can't handle it anymore it is very annoying. Oh and not sure if this helps to determine the problem but whenever I step on the pedal to accelerate, especially when I step on the pedal till it's last, the car doesn't accelerate immediately, it takes a while to respond, 2-3 seconds if not more. And the click sound I mentioned above, also happens even when I am on park and the A/C is on(not sure if it doesn't come when A/C is off though). -Spark plugs had been changed recently. -Engine motor mounts had been changed recently too(so no way it is the problem). -Oil pump had been changed along with the spark plugs and the engine motor mounts.

Answers from the Automotive Experts

Jessica Howe, Automotive Expert & Coach at AskPatty.com

Hello, 

Thank you for writing in. Lets start with the idle RPM. When an engine is cold, the computer runs based on a preprogrammed setting that typically keeps the RPMs higher. As the engine warms up and hits "operating temperature", the RPMs typically drop down. A lot of Chevy trucks and SUVs do idle at 500 RPMs. If this is unusual for your truck once it is warmed up (typically 195-210 degrees) then you may want to look into the issue further. Otherwise, you seem to have more pressing issues to address (which may or may not be related). 

The lack of acceleration and the clicking noises are both too generic to be able to diagnose effectively without seeing the vehicle. A lack of acceleration can be engine related or it can be transmission related. A delay of 2 or 3 seconds is alarming, and you will want to have that issue looked at sooner than later. 

On that note, the AC is powered off of the engine through the drive belt. When the AC is on, it may be pulling more power than it should from the engine and causing a drop in horsepower. Turn off the AC and see if the vehicle gains some of its power back. If it does, you need to get the AC compressor inspected. Although, it is not likely that the AC would cause an extreme delay when pressing on the gas like you explain. It can however cause clicking sounds. 

A clicking noise coming from the engine may or may not be related to the other issues you seem to be having. Only further inspection will tell. Rule out a low oil issue by checking the oil level and condition. Make sure the oil has a good color and is not gritty or foamy, in addition to being at the correct level. Low engine oil and oil pressure can lead to valve train noise (often identified as clicking). 

In other words, you have several complaints that may or may not be related. Some issues seem more pressing that others. Prioritize the lack of acceleration/delay when pressing on the gas. From there, try to locate the source of the clicking sounds. Then you can consider looking into the idle RPMs. Good luck!


Contribute to this question:


blog comments powered by Disqus

Related Acura MDX FAQs


  • So I just got my oil changed at Jiffy Lube, and they said my car, a GMC Terrainm has a ... Read More

  • My car does something strange after a few minutes of idling. The engine revs itself up ... Read More

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities