AskPatty Certified Female Friendly Logo

I have the large hose coming from the evap canister in the rear of my xj and it goes nowhere. It stops underneath the car where the brake pedal is. I think its supposed to go to the evap pump but my jeep doesn't have one. I bought it 2 years ago. I don't want to leave it open there. Should I put in a pump? Plug it? The OEM manual says some came with the pump and some didn't. Thanks, Dave

Contribute to this question:


blog comments powered by Disqus

Related Jeep Cherokee FAQs


  • My 1996 jeep Cherokee stalled out when I came to a stop sign and wouldn't start back up. ... Read More
  • My 1999 Jeep Grand Cherokee is sputtering at Idle,every time it sputters the radio also ... Read More
  • dean WANT DEAF DRIVER CARD Read More
  • I was driving at about 60mph and something broke and the motor started missing. After ... Read More
  • When stepping on The gas ir won't shift unless I hit 4000 rpms or it won't even shift if ... Read More
  • Turning signals don't work but bulb are good and flasher work Read More
  • Weekday is causing temperature to drop when driving my 99 Jeep Grand Cherokee Laredo. ... Read More
  • My oil change light came on but I just got a oil change and it smells like hot stream Read More
  • Wbere is the turn signal or flasher relay on this year grand cherokee? 144.4 Read More

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities