AskPatty Certified Female Friendly Logo
My oil pressure sensor connecter was leaking oil, a lot to, so I changed out the oil pressure sensor , thinking it failed. The one I got from napa has two prongs inside the sensor it's self and the new connecter has two wires , when the O.G one had only one green wire on the connecter and one prong on the sensor what do I do. Is it the wrong part ,or do I modify it

Answers from the Automotive Experts

Amanda J. Pierce, MBA Derek, Sounds like you have the wrong sensor, you may need to return and clarify further the type of model you have.

Contribute to this question:


blog comments powered by Disqus

Related Jeep Grand Cherokee FAQs


  • I am seeing steam from the dash and am having an overheating problem. What could be ... Read More
  • while driving my oil pressure okay surely will drop to zero. After a time it will go ... Read More
  • I bought my Jeep used from a dealership. It had 27k miles and one owner. It was 2 yrs old ... Read More
  • Can an On-Star be installed in my wifes 2005 Jeep and, if so, what would would be an ... Read More
  • I have a 97 jeep grand Cherokee...it tends to turn off in the middle of driving ... Read More
  • How do I know if I need oil? Read More
  • I LIKE MY CIG LIGHTER TO WORK WITH THE KEY OFF WHAT KIND AMPS FUSE CAN I USE THANK YOU ... Read More
  • I have a 2004 Jeep Grand Cherokee with almost 70,000 on it. I have heard that when they ... Read More
  • I hear a sloshing sound under the hood, sounds like an aquarium, 1/3 full Read More

Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities