AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionAutomotive Advice - Page 39 of 627


I have a Kia Sorento and it has stopped running. The crank wouldn't stay running. Someone told me it was the fuel pump, so I replaced it and it wouldn't stay running. I replaced the fuel relay and crank up. The car ran for about a week and then it died again. This keeps happening and I dont know what to do. Why does the fuel relay going ...

My Toyota 4Runner vehicle stalled on freeway in traffic but soon after I was able to drive it again. The AT/Tem light came on two days ago after a trip to and from an elevation of 2000 feet and about 80 miles. Later I check the tran oil, and it was black. I have owned it more than 8 years and 125,000 miles and have not had any service on the ...

I have a 2006 Dodge Durango with a whistling or wind noise on the drivers side outside of the SUV. It does not happen all the time, It happens off and on while driving the car. No, I am not dragging a limb or branch and there are no leaks from underneath because it is kept in a garage. How do I fix this problem?

I have a Honda Accord Ex and everytime I come to a complete stop and take off, my doors sound like they are locking again. Also, my alarm doesn't work anymore since that started. Do you have any idea what could be causing the problem?

Over the last couple days, I've heard a squeaky noise in my Hyundai Elantra that sounds like its in my steering column or low in my dash while driving. It gets more pronounced when I drive over a bump or heave in the road. It sounds like two pieces of rubber rubbing together. I hear a similar noise if I idle and just turn my wheel ...

I have a 2009 Dodge Avenger and it keeps going into limp mode. It works for a few weeks or months then it happens again. I changed the computer, the throttle body, the spark plug coils, and the codes that come up are not any help. I've also checked the cables from battery and alternator. .I've seen a lot of people have had this problem ...

I have a Ford F-350 and I was wondering if a gas gem module can fit a diesel?


Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities