AskPatty Certified Female Friendly Logo

Automotive Advice

At AskPatty, we focus on giving the best automotive advice for helping people with their car questions. If you have a car question, start by asking our automotive experts. You can also use the search bar in the top right to search for a specific issue. All car questions are welcome and we look forward to helping you!


Ask a QuestionAutomotive Advice - Page 2 of 659


Sir i own a 660 cc Japanese Suzuki Alto, automatic . Recently i am having the problem of power loss (sometimes) When i start my car and put it in D mode. And push the gas pedal nothing happens for a second and suddenly the car picks up the acceleration. Also, i have noticed that my creep speed is slower than normal. When moving in traffic it does not ...

i have literally a flawless car and i installed a "vertex" performance chip ]under the hood and after so many days i got a check engine light . WELL I FOUND OOUT YOU CAN DO A LITTLE car hack code and i did it and it said i had somthing worng withthe oxygen sensor or soomthing .. thats where that chip is actually pkugged into the toP OFF sorry ...

The instrument panel on the dash for the transmission doesn't light up so I can't see what gear I'm in. Thank you

My battery had to be jumped and now periodically a loud clicking noise can be heard coming from dashboard when I start the car and when I’m driving, I couldn’t find any info in manual. Any ideas what is causing this?

My car is having trouble starting. Not every time I start the car, but it’s happening almost daily now. The only way I can describe it is an extended cranking time. It was about 3 solid seconds of cranking/turning over, but today it cranked for closer to 5 seconds. When it finally started, it sounded like it barely had enough juice to start. Then ...

My Jaguar starts, but does not accelerate.

Hello~ The A/C & Air Circulation lights flash intermittently when the fan is turned on. When the fan is off, the Air Vent light flashes. It's still heating the car but the defrost isn't working that well. Could this be a fuse or something much bigger, like a serpentine belt? Help!


Need Car Advice?

Ask The Experts!

Looking for a New or Used Car?

Search for our Certified Female Friendly® Car Buying Marketplace locations

Help Our Charities