AskPatty Certified Female Friendly Logo
I have a 2006 ford explorer Eddie Bauer. The radio and dash indicators flicker and the truck shuts off. Also the heat does not get hot. There is plenty of coolant and thermostat is working. What's the problem ? Help please!

Answers from the Automotive Experts

Amanda J. Pierce, MBA Mike, #1 I recommend you check your ground wire first! #2 you may want to inspect your heater core and the blend doors in your dash HVAC. At times the cable controlling your blend flap doors from heat and a/c become disconnected to where they 'block off' the temp your seeking.

Contribute to this question:


blog comments powered by Disqus

Related Ford Aerostar FAQs


  • I need to replace my battery my husband disconnected the cables now the battery won't ... Read More
  • My Ford truck tires are 275 70r18 if I went with a 17 inch rim. What's the biggest tire ... Read More
  • I have squeaking when going over bumps. The tires were "cupped," had them replaced two ... Read More
  • What number fuse is for the cruise control on a 1993 Ford aerostar xl? Read More
  • How do I get the temperature gage on the instrument panel to function, because it's ... Read More
  • What is the fuse number 20 under the hood of a f250 super duty? Read More
  • What is the average cost to replace a power steering pump? What is the average cost to ... Read More
  • 0ur 1993 Ford Van heater/ac fan will only work on high level. We replaced the switch and ... Read More
  • cruise control doesn't work. Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities