AskPatty Certified Female Friendly Logo
My son's 2000 Nissan Xterra would not start. He tried until the battery was near dead. The next day I went to help and it started but ran rough. We drove it to an auto parts store to see what code was coming up with the service engine light on. They said it was the knock sensor. We got it home and I took the top of the engine apart to replace the sensor. After making the replacement of the sensor and putting it back together it started but runs rougher than before. I have cleaned the MAF sensor with the proper cleaner, removed the air filter and moved the district or clockwise to get the best idle. It still runs rough, fails when reved. There is a light clacking sound from the passenger side; lifters or exhaust perhaps. The distributor, wires and plugs are 8 months old. There is no check engine light on and there is little power if placed in gear. Help please?

Contribute to this question:


blog comments powered by Disqus

Related Nissan Xterra FAQs


  • I just bought a 2000 Nissan Xterra and it runs great however, when i put it into D, it ... Read More
  • When I fill the tank on my Nissan Xterra, the nozzle shuts off every few seconds. Every ... Read More
  • After changing out the transmission computer module on a 2000 Nissan Xera. Will I need to ... Read More
  • I just purchased a used 05 Nissan Xterra, V6. I'd like to put the best oil filter and oil ... Read More
  • My Nissan XTerra blower motor only works part of the time. When it won't come on, if I ... Read More
  • How many cylinders does my 01 Nissen xterra se have Read More
  • Hi Ladies, I have an issue with my 00 Xterra. I have a very strong gasoline odor coming ... Read More
  • Hi Patty: I have a 2000 Nissan Xterra with 183,000 miles. It has run really well up ... Read More
  • I have a 2001 Xterra and last summer paid to have the belt replaced because there was a ... Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities