AskPatty Certified Female Friendly Logo
My TPMS light on my Chysler Sebring continuously flashes then eventually becomes solid every time I start my car. I have checked all tires for pressure and all are fine. I have also replaced all four pressure sensors in the tires in the past year and all synced up and worked correctly after replacement. Now the light is flashing then turning solid every time I start the car and I can't figure out why. Any thoughts?

Answers from the Automotive Experts

Amanda J. Pierce, MBA Jeremy, I recommend that you visit a local repair facility so I can hook up the obd2 tester, and have your TPMS readings checked that are communicating to the ECU.

Amy Mattinat, Owner and Author at Auto Craftsmen Ltd Hi Jeremy, Have you check the air pressure on the spare tire? Have you checked to make sure the sensors are working? Just because they were connected when installed, doesn't mean they are all working or connected now.

Contribute to this question:


blog comments powered by Disqus

Related Chrysler Sebring FAQs


  • Hello about a week ago my Chrysler Sebring convertible JX seems to have a problem well ... Read More
  • The heater will not blow any air at all thru my defroster Read More
  • my car takes along time to heat up and u have to turn the heat up on hi i need help... Read More
  • We recently when adding air to a rear tire the valve Stem split so the following day had ... Read More
  • Should I have a synthetic blend oil change or a synthetic oil change? My mileage is ... Read More
  • Where is the fuel filter located on my Chrysler Sebring? Read More
  • Hi .. I recently got this car a couple years ago and have done my best to keep up with ... Read More
  • where are the grease points located on my 2004 Chrysler Sebring Read More
  • While driving, my 1997 Chrysler Sebring jumps or misses. Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities