AskPatty Certified Female Friendly Logo
I have a 2000 Cadillac sts I have had the car for about 2 years and have quite a bit of work into it, It just recently started saying "service suspension sys" It will go away and come back on. It first came on a few days ago and then went away and then just today it came back on. I just took to the shop about 2 to 3 weeks ago for a a new alternator I don't if that would have anything to do with it. It also has been making a weird clicking noise when I turn the wheel or hit a bump. I have looked online and found a few different answers so I am just wondering if anybody has had this happen and knows what it is.

Answers from the Automotive Experts

Amanda J. Pierce, MBA Jessica, It sounds like you may need to have your CV boots inspected in the front end, over time these rubber sleeves/boots can tear and sling grease causing them to dry out.

Gail Dunn, Owner at Women's Automotive Connection Jessica Your shocks, struts, and ball joints constitute the wearable portion of your suspension system and should be checked by professional as this will affect the wear on your tires.

Gelina Aquilina, Service Advisor / Mechanic at Sounds like it may be a bad axle or wheel bearing. If would need to be diagnosed and if you have a warning message, a mechanic might find a code for it in you ECU.

Contribute to this question:


blog comments powered by Disqus

Related Cadillac Sts FAQs


  • 01 Cadillac STS cornering light replacement Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities