AskPatty Certified Female Friendly Logo
I just bought a 2000 Nissan Xterra and it runs great however, when i put it into D, it take a few section to take off, but if i put it into 2, it engage right away. While in motion, it runs great and shift smoothly. Is my transmission about to go out or is there a module that i can replaced. Thank you for your time.

Answers from the Automotive Experts

Amanda J. Pierce, MBA Khanh, I suggest taking approx. 1/2 a second between shifting, you may be moving the gear shifter too quickly for ample response time from your transmission.

Gail Dunn, Owner at Women's Automotive Connection Khanh If your transmission is slipping like that, you should find a good transmission specialty to have it checked out. It is a symptom of a problem, but only an expert can tell you what that might since it is a closed system. Good luck,

Contribute to this question:


blog comments powered by Disqus

Related Nissan Xterra FAQs


  • My son's 2000 Nissan Xterra would not start. He tried until the battery was near dead. ... Read More
  • When I fill the tank on my Nissan Xterra, the nozzle shuts off every few seconds. Every ... Read More
  • After changing out the transmission computer module on a 2000 Nissan Xera. Will I need to ... Read More
  • I just purchased a used 05 Nissan Xterra, V6. I'd like to put the best oil filter and oil ... Read More
  • My Nissan XTerra blower motor only works part of the time. When it won't come on, if I ... Read More
  • How many cylinders does my 01 Nissen xterra se have Read More
  • Hi Ladies, I have an issue with my 00 Xterra. I have a very strong gasoline odor coming ... Read More
  • Hi Patty: I have a 2000 Nissan Xterra with 183,000 miles. It has run really well up ... Read More
  • I have a 2001 Xterra and last summer paid to have the belt replaced because there was a ... Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities