AskPatty Certified Female Friendly Logo
After changing the alternator, I notice that the car is running rough and the check engine light is on. What could it be?

Answers from the Automotive Experts

Amanda J. Pierce, MBA Regina, You may need to double check that you replaced all vacuum lines, which may have been removed. You can always visit your local auto parts store, where they may be able to hook a trouble code reader for free. This may give you more of an idea, also if the air filter/breather box was removed you may need to check if there is a sensor that was not replaced there too! Hope this Helps!! A. J. Valle

Contribute to this question:


blog comments powered by Disqus

Related Ford Focus FAQs


  • Hi their i have just bought my 2009 ford focus and i cant seem to find out how to sync my ... Read More
  • I have a 2000 Ford Focus SE that recently stopped working. battery light was coming on ... Read More
  • I am so ignorant about car maintenance. Do you know of any web resources where I could ... Read More
  • Twice in past week, it appears my automatic transmission gears shifted downward or ... Read More
  • I just bought this focus from a old friend (1st mistake) 2000 ford focus zts 3 dr ... Read More
  • Engine Light on a Ford Focus 2003....Code P 2008.Car works fine though. Read More
  • I recently had my tires replaced and since then my brake light is on. My brakes are not ... Read More
  • Hi Patty! I bought a 2009 Ford Focus on August 15th, 2012. Today the dealership told ... Read More
  • When using a auto repair shop, does the customer get the Core charge back or the shop Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities