AskPatty Certified Female Friendly Logo
122k mi. - started car up for return home after work. Speedometer not working, ac not working, turn signal not working...none of the environmental temp controls working... what is the problem this time?

Answers from the Automotive Experts

Suzanne Grego, Technician at City of Philadelphia Fleet Management Sheila, You could have an instrument cluster problem or a wiring issue. You'll need to take your vehicle to a qualified technician to have it properly diagnosed. If you are having trouble finding someone you trust, check out the list of female friendly shops on Ask Patty. Suzanne

Contribute to this question:


blog comments powered by Disqus

Related Mercury Cougar FAQs


  • During extreme cold or heat my car often makes a humming noise while I'm slowing or ... Read More
  • Why does the car shake when driving at low speeds? Read More
  • Where can I get cash for another used car? My car just rusted out and will not pass ... Read More
  • My check engine light is on and I am having a problem getting my car inspected, I do not ... Read More
  • Name the more reputable car repair services in the East Cleveland, Ohio area Read More
  • I have a 99 mercury villager with 80000 miles. For the last couple of months I have had ... Read More
  • how do you know if your water pump is going bad. I was told mine was, but I am thinking ... Read More
  • my son is spinal cord injury c6 c7. We have a 1995 mercury with a blown head. Is it worth ... Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale


Help Our Charities