AskPatty Certified Female Friendly Logo
My Mercedes ML 320 1998 has recently had a new key and switch (device in the ignition. Two weeks later I started the car up and the handbrake warning sound stayed on, the ABS and ETS lights stayed on. I released the hanbrake and drove off. I noticed the petrol gauge was fluctuating and it wasn*t changing gear. I stopped. Switched off, and restarted. It was ok. It has done this only once more in about six weeks. What could it be. My local Mercedes garage don*t speak good English here in Spain.

Answers from the Automotive Experts

Lori Johnson, Owner and Instructor at Ladies Start Your Engines Dear Judi, It sounds like there may be a problem with connections to the dash board lights. It could be that when they replaced the ignition switch that they had to disconnect some of the wiring connectors to the dash that control the lights and gauges. There may be a loose connection at these wires. I would suggest that you take someone with you that can communicate with them and explain exactly what's happening and when. This way they will have a better idea of what to check. Good Luck. Lori Johnson

Contribute to this question:


blog comments powered by Disqus

Related Mercedes-Benz ML320 FAQs


  • How much would the repair of a sunroof on a ML320 Mercedes (2001) cost Read More
  • I have a 99 Mercedes ML320 and it*s time for service, what all does service include. ... Read More

Need Car Advice?

Ask The Experts!

Find Cars For Sale

Help Our Charities